Cannot Read MagnusS3 temperature with Mercury API

Forums Forums General Discussions Cannot Read MagnusS3 temperature with Mercury API

This topic contains 1 reply, has 2 voices, and was last updated by  Greg Pitner 7 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1342

    Nigel Harrison
    Community Member
    • ★★★★

    I have a Thing Magic Sargas reader that I am using with the Mercury API.

    I have used the excellent Application note AN002F40 and can read the tags sensor code, RSSI, user memory etc without any problem.  The code is almost exactly as the example on page 6 & 7.

    However I cannot read the temperature code.  The line r.ParamSet(“/reader/gen2/4t”, 3000) throws an exception at run time.  If I remove this line the code runs but returns no results.

    I am connecting to the reader using llrp over ethernet rather then the USB serial connection on COM5 in your example.

    I have downloaded the latest API and updated the Sargas firmware to the latest version.

    This is now very urgent as I have to demo the system in a few days.

    Any help or suggestions much appreciated.

    Thanks

    0
    #1343

    Greg Pitner
    RFMicron Team Member
    • ★★★★

    Hi Nigel:

    First, this may be just a typo in your message, but the parameter is “\reader\gen2\t4”, not “\reader\gen2\4t”.

    Even with that line removed, it should still be possible to get the temperature value, just with possibly reduced accuracy. Our testing has been with the USB serial connection; is it possible to try that connection mode, just as a debug step?

    0
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Axzon (formerly RFMicron)

3700 N. Capital of Texas Hwy
Suite 570
Austin, TX 78746
Tel: (512) 535-4647
Axzon.com